Foundry v2.3.0 and Potion Pack v2.0.7 updates are here

Good afternoon everyone! I hope you’re all doing well. I’ve just pushed out a couple of updates for Foundry and Potion Pack that you’ll want to grab, especially if you’re excited about the upcoming Alloy v3 update that is coming soon.

Both Foundry and Potion Pack include some under the hood changes for the upcoming Alloy release, which I’ll be talking more about Alloy v3 in the coming days, so stay tuned for that.

In addition to the Alloy changes in these two updates I’ve also included a brand new stack in Foundry and several new features in Potion Pack’s Form Pro stack.

Here’s a quick video to look at the new Quick Access stack that is included in Foundry v2.3.0:

In addition I’ve also got a new blog post up on the Foundry site about this new stack as well:

Keen-eyed reads will realize that also means there is a brand new Foundry Blog as well. I’ve ported over some of the old blog’s Foundry and Alloy related articles, as well as written a new post about these two updates and the Quick Access stack post as well.

The Release Notes for each of these updates can be found here:

Foundry v2.3.0:https://foundry.elixirgraphics.com/release-notes/

Potion Pack v2.0.7: https://foundry.elixirgraphics.com/addons/potion-pack/release-notes/

I’ll be posting about the Alloy v3 release over there on the blog as well as here in the forum. There’ll be lots of details, videos, screenshots, etc. that you won’t want to miss.

10 Likes

Forgot to post a link to the Documentation page for Quick Access stack as well, so here it is: https://foundry.elixirgraphics.com/documentation/quick-access/

2 Likes

Thank you Adam, the change in the DatePicker is great :slight_smile:

3 Likes

Just a small observation - has something been missed with the new Atium name?

2 Likes

Ah, yes it looks like I forgot to copy-paste that in. I’ll get it in the next one. I was focused on something else I think.

Bonus points, or as comic book fans call it – the No-Prize, for anyone that can tell me what either Chiralium or Atium are without looking them up on the internet.

Just pushed out Foundry v2.3.1 to the server. It fixes a bug with the Margins stack:

  • Fixes a bug with the View Height (vh) settings for Tablet and Desktop breakpoints which were mismatched. If you’ve selected (vh) for either the margin and / or padding settings for the Tablet and Desktop breakpoints you will have to re-select them.

Looks like something went wrong with the updater. I re-installed Foundry 2.2.x and did the update again, the third time then all went good, Sections is working again and also Quick Access appeared.

1 Like

Hi Heiko,

had the same issue. Thanks for the tip. I reinstalled as well and was lucky the second time I updated. :+1:

Hans

2 Likes

Just wondering if anyone else has had the issue where adding the Quick Access stack causes stack add buttons to disappear (well white on white anyway). Up to date versions of RW, Stacks, Catalina. Also tested on a fresh project and 2 different Macs.

From this


To this

Looks like a bug for sure. I’ll take a look at it as soon as I can. About to sit down to dinner though.

2 Likes

Have dinner. It’s no big issue!

Have it fixed I think. I’m going to hang on and wait to update tomorrow. I’m waiting on another user with a bug report to send me a project file. I’d like to make sure his is not a bug with Foundry before I push out an update. That way if I can fix his bug quickly, too I can get both in the same update.

3 Likes

Hi Adam,
thanks for updating Foundry and PP - updating and refreshing all my customer sides were completed well - with one exeption for me.
Working with freshest RW/Stacks…and whole FoundyPackage;-)
Pls see here - inside LazyLoad with RemotePictures > https://ofengeschichten.de/team/
It works fine before updating, but now only short after scrolling - magic!
Do have any ideaß
Greets
Roger

I don’t think I understand what you’re trying to convey.

I’m away from my computer right now but everything is loading fine here on my phone.

Please provide me more details to help me understand the problem.

Hi Adam, you are right - if you are at your i.g Iphone in Portrait it works fine. At my Macbrowser (Mozilla) and refreshing/scalling it, I see often this circling around.
Bildschirmfoto 2020-11-13 um 18.37.09
Pls check also my landingpage www.ofengeschichten.de in landscape-mode if you are at your phone - than at the top, you’ll find the button »Kurse«. Left picture is »Janna« and same effect…

I’ve just created a test project using Lazy Load, here: https://elixirgraphics.com/test/test-for-lazy-load/

It uses both remote and drag-and-drop images to test against both. Please give it a try and let me know if you run into problems. For me it is working as it should.

To be clear, I see the problem on your page, but I cannot replicate it here.

If you want to share your project file with me I can have a look though.

Ok, thanks Adam for work-trough - will send you the RW.file
Thanks for your attention.
Best.
Roger

…ok, I pasted in your nice cat-pict 37 k - refreshed my homepage www.ofengeschichten.de - clicked at the top »kurse« - and MODAL opens … the same…

pls. expand the format of your browser window - and the cat is smiling at you;-)
everything is fine - but why?
Greets
Roger

First thing to get out of the way – it is not currently designed to work in a modal. Lazy loading is traditionally meant to activate down page as the site is scrolled. It can’t do that on hidden content in a fixed-position modal.

Next up – You’re using a LOT of 3rd-party stacks that I do not have, so I’ve removed them from the page just so I can look at your project in Preview Mode. When I load it in preview mode all of the images load as they should (aside from the image in the modal, which should not load). Here’s a video showing what I see: https://d.pr/v/PIhm7u

If the images you see in the video are not loading properly for you, then I would deduce that something on your page, that is not a Foundry stack, is causing a problem. You can investigate by removing a few items from the page at a time until you find the culprit. You do have a lot of nested complex stacks on the page so I would not be surprised if something is causing a conflict.

Going back to the image in the Modal – I might be able to make some adjustments that would allow this to work. I’ll give it a look. If so that added functionality would be in the next update.

Ok Adam, thanks for your immediate overview an response.
Will check and answer it tomorrow;-)
Best to yours and greetings to all Weavers around.
Roger