Trouble with HTML Script


#1

I’m having some trouble getting the html script for an audio player to play within Foundry. My sandbox site is built in Foundry and doesn’t show the player from VoiceZam. The Foundation page is simply the exact home page built in Foundry, but I changed the theme to Foundation.

HTML page is an RW HTML page with nothing else on it and the Launch 2 is the theme Launch 2 by Yuzool. I checked several other themes and had no issues.

Any ideas would be greatly appreciated.

I realize of course, I could build it in Foundation - Captain Obvious. :wink:


#2

With this being some code that is being inserted from another service I can’t say that I’ll be able to do much for you, but if you send me your project file I will take a quick look at it.

If I grab the iframe that is inserted on the HTML based page, via your script, and paste that into a Foundry page it works fine. So I suspect there’s something up with the call to your outside service. Maybe a conflict somewhere. If that is the case the two things may just not be compatible. We’ll see.


#3

If I eliminate the required javascript.js file from the Foundry theme your player begins working as it should. That said, this file is a part of the RapidWeaver theme API. I suspect the audio player works in some other themes because they’re likely loading the javascript file for the API in the <head> of the page, while Foundry loads it at the bottom of the <body> instead. This is not something that can change unfortunately.

You might look into an audio stack on the Community site to see if that approach would work.


#4

Thanks for figuring this out Adam. Unfortunately she is pretty set on using VoiceZam as it is widely used in her industry. I’ll find another way. :smile:


#5

Glad I could narrow it down for you. Good luck with your project!


closed #6