Alloy Editor image upload

Hi all,
I have a problem with the image upload in alloy editor.
It seams that there is already a problem when i add a new post (see screenshot)
It seams there is a broken link (sorry, I am not sure if I use the right words)

I use PHP 7.0.33

I use the newest Version of Alloy I bought some weeks ago so I never use “the old” Alloy editor without the new image upload.

What I am doing wrong?
Many thanks in advance for help :wink:

Hi @Toto

A couple of things you might try –

  • Make sure your filenames do not contain any special characters. This include umlauts, tildes, etc over characters as well as spaces. Keep filenames simple.
  • Make sure your images folder that was created by Alloy on your server has write permissions. Permissions of 755 should suffice.
  • If that doesn’t clear it up, you may try updating to PHP 7.2 and see if that clears things up for you.

Hi Adam, thank you for your reply.
Unfortunatly i could not solve the problem.

I made an “testimage.jpg” (see screenshot)
When i upload the picture in the editor i could not see the thumbnail in the preview.
The folder “image-uploads” remains empty, the “testimage.jpg” is not inside after saving the new post.
When i take a look at the new blogpost there is only the alt tag seen “Bild” (see screenshot)

I changed the PHP Version to 7.2.22 (see screenshot)

I had write permissions. (see screenshot)

Do you have another idea for me? Thanks a lot and sorry for the inconvenience and the work I do to you.

btw
For a test I made a second installation on another server with another hoster and i had the same problem with the image upload.

Best regards
Toto


Good morning @Toto

Very strange. Let’s see if we can’t get to the bottom of things. I’ll need you to send me a ZIP file containing the following items:

  • Your PHP error log file.
  • A copy of your RapidWeaver project file for this site.
  • The image you’re trying to upload.

You can email the ZIP file to adam at elixirgraphics dot com. If it is larger than 5mb or so you’ll need to send it via Dropbox or a similar service.

As a quick test I threw together an Editor stack page and it is working here as expected, so it likely has something to do with your setup or server.

All worked out. @Toto had simply setup the Editor incorrectly, placing it in the main site folder instead of its own folder. With that changed everything is back to working as intended.

Thanks again Adam :+1::+1::+1:

1 Like

Hello, I have exactly the same problem :disappointed:
However, I had put The Editor in another folder (here Editeur in french).
Look: cyberduck
Do you have a solution?
Many thanks in advance for help :pray:t3:
Paty

Hi @Paty – You don’t likely have the same problem as @Toto did. That said, did you follow the installation and editor tutorials videos step-by-step? If not please do so. Doing so will get things setup as they should be.

The tutorials can be found here:

After you’ve gone through the tutorials step-by-step, if you still have a problem I’ll need you to provide me the following things in a ZIP file:

(1) Your project file
(2) Your posts folder from your server
(3) Your image-uploads folder from your server

I’ll also need to know what version of PHP you’re running on your server as well as it might be helpful to know who your host is.

Hello,
Thanks for your answer :slightly_smiling_face:.
Yes, I followed the videos “Editor Setup” Part One and Two in particular :nerd_face:.
My PHP version is 7.3.10 (Host = One.com).

.
Here is the link for downloading the files:https://m22.be/LeVerger/FichiersVerger.zip
Another strange thing: the markdown text in bold doesn’t appear (sorry, I’m cursed😓).
Thanks again!
Paty

The blog address: http://m22.be//LeVerger/

Bold isn’t working where? Blog body text? Title? Somewhere else?

Also, your ZIP file only contains your exported site and not the project file.

Hi, in the Blog body text:

Oh, sorry, here you are:
BlogVerger2.zip (1.9 MB)

Let’s begin with your font problem – You’re loading the same font three times on the page in the Typeface stack. The final time you load it you’re omitting the bold variation. You should only be loading a font once in Typeface and assigning it all of the weights you’ll be using on the page. This incorrect configuration is likely your problem with the bolding.

As for your images – It looks like you’ve got your URL pointing somewhere strange. This is because of your configuration of your publishing address in RW I suspect.

This is where images are pointed, due to your configuration:

This is where the actual image resides:
http://m22.be//LeVerger/image-uploads/LVerger_Photos04.jpg

This is the same problem as this thread:

Forgot to upload this image as well in my last post. This is the website address where your site it located.

You’ve entered: http://customers/3/b/6/m22.be/httpd.www/

You should have entered this instead as this is the actual address of your site: https://m22.be/

So when the Editor created the URLs in your post it put the baseurl from your publishing settings in thinking you had supplied the correct location, as it only knows what you tell it. Thus it created the wrong URLs in your blog posts.

Correct this field with the right address, “Republish All Files” and then edit your post, or create a new one, and re-upload your image and you should be good to go.

Waow! Thank you very much! :+1:t3:
I’ll try that
Have a nice day(?):sunny:night(?):crescent_moon:
You are the best🥇

Thanks for the kind words.

That said, try it out and let me know how it goes. You might be best just deleting your posts from your posts folder as well as the images in your image-uploads folder and starting again just to be sure if it isn’t too big of a pain.

Okay, good idea :blush:
Thanks :pray:t3:
Merci beaucoup

YES! All it works!
It’s wonderfull :star_struck: (< first time that i use this emoticon)
:dancer:

Glad to hear. Crazy how much one URL can make a difference, huh?!