Weird Foundry/Easy CMS Issue


#1

I’m having an issue on a website I manage (built with Foundry) where on pages that I’ve added EasyCMS it hides the image inside the Media Group stack regardless of whether or not it’s being shown on a mobile device.

You can see the issue here: https://peterboroughjiujitsu.com/peterborough_clubs/peterborough_ymca.php

The logo, which is inside a media group stack is hidden on desktop, though it’s only set to be hidden on mobile.

Anyone else run into this? You can see if functioning properly on the home page: https://peterboroughjiujitsu.com


#2

Hi there @SanityBox – The logo appears to be loading here in Safari at the desktop breakpoint:

So I decided to take a look at your image in Firefox and saw it was missing. The lead me to look at your image in Photoshop. Looks like your image is 300 dpi. This is something that some browsers will tolerate and other will not. I’d start by creating a new logo image at 72 dpi. Replace your current one and then do a Republish All Files.


#3

That’s super weird, since the logo wasn’t showing on Safari for me, but it only failed to show on pages where Easy CMS was installed. It works fine elsewhere. But it’s clearly working in your screenshots.

I went ahead and made the change, but I’m still seeing the same behaviour. (Cleared cache, private view just to make sure.)


#4

If it is only occurring on pages with the Easy CMS, you might need to check with that developer or try a different CMS solution – there are a lot out there. Perhaps something EasyCMS is doing is disrupting the float for the image in the media group that places it to the left or right of the Media Group content.

If you visit this page you’ll see this section on the page:

The Control Center icon and the content to its right are a Media Group stack. They appear fine for me in Safari, FireFox, Chrome, etc. Same for you?


#5

Yeah, it’s only occurring on Easy CMS pages. I’ll send a message to that developer. Thanks!


#6

In the event anyone else runs into this issue, dropping .media-object{max-width:none} into the css on the pages with EasyCMS resolves the issue.