Tips to prevent forms from being treated as spoofs?


#1

I’m using Foundry’s Form and Form Pro on a commercial domain (hosted by Dreamhost). If I tick the box for “send using my email address” I can get the form to deliver the email to my .edu address, but it is always marked as insecure (and shuffled into a spam box).

Its doing this at the server level, because I get a line warning about spoofing and a link to this Microsoft article with each message.

Is there anything I can do to prevent this on my end, or is my only recourse to contact the college and ask them to whitelist my domain?


#2

Usually the issue is not caused by the form and even by your account. The problem is generally from the shared servers. Your domain is with others domains hosted on a server. Could be that one of those other sent bulk mails recognized as spam. In this case all the other can be marked as spammers.
The best to do is use an external server as Direct mail, Mailchimp etc, etc. and leave your server free of those charge.
Hope to be clear cause EN is not my primary language.
To whitelist the domain the request should be to the host company that submit the request in the proper place. The college can’t white anything I guess.


#3

This could be due to having the email sent from an address other than the domain’s. You could try setting up an email account on the site’s domain and use that as the send address and see if that fixes the problem.


#4

Thanks. Does MailChimp and other services like that work for email coming in? I thought that those were mail delivery services only?


#5

If I input a “send-to” address that is on the same commercial .org domain as the form and I tick “Send using my email address” it is received just fine. But, I need it to be sent to a different, .edu address.

If I input the “send-to” address as the .edu email with the “Send using my email address” ticked the mail is delivered but marked as high-threat of spoofing as written above.

If I input the “send-to” address as the .edu email OR the .org email without ticking the “Send using my email address” box I get nothing delivered at all to either address.


#6

I’ve found a work-around. Dreamhost’s panel lets you create ‘forward-only’ addresses. So, I’ll just have to create those with the host’s domain and have them set to forward the content to the .edu addresses.

It creates some slightly confusing To: and From: fields, but it definitely works and prevents the messages from getting lost or filtered as spoofs.