Thunder pack: Sort item styling


#1

Hi, how do you remove the default stying on the sort item(s)? There is, i think, a 20px white border with a drop shadow surrounding any sort item I add. Would like no styling applied just image, any help will be appreciated, thanks!


#2

Happy Sunday @stackJunkie

That is not a feature of the Sort stack.


#3

Hi, hmm… Can you consider it for an update. Because now i have to go to a 3rd party “sorting” stack or start looking for the css to avoid that styling.


#4

I’ll add it as something to look at adding in the future. Right now I have a few things I need to get to first though.


#5

There is 20px of padding inside a rounded corner box (1px border) which has a drop shadow.

This will remove all three. You probably don’t need the “!important” keyword. I try not to use them unless necessary, so try without and add them if needed. I’d paste this in the page’s CSS area.

I’m not sure exactly what you are trying to do, so you may not need to remove all three. If you still have issues, post a link to a page and we’ll go from there.

.sort-internal-padding {
	padding: 0 !important;
	border: 0 !important;
	-webkit-box-shadow: none !important;
	-moz-box-shadow: none !important;
	box-shadow: none !important;
}

#6

Thank you for the css snippet!


#7

It worked. I was just trying to create a portfolio using the sort/filter stack like this


#8

That looks great! Thanks for posting the image of your layout.


#9

Great user support :+1::smile:


#10

Working on this now. Should be in the next update, which would be v1.0.2.


#11

Great news, thank you!


#12

Just added in v1.0.2. If you’ve not grabbed the update already, it should now be available for everyone. Check for updates in Stacks.


#13

Thank You for the update.

How can I remove the ‘Filter’ button? All Category and Filter fields are empty in the sort items.
Typing into the search bar, automatically narrows the display to those items whose content match the search field’s - this is all I would want to do; the persistent Filter button has no function in this case. But I could not find the setting to make it go away . . .

Thank You again.


#14

You can simply delete the filter buttons in Edit Mode. There’s a separate checkbox in the settings that toggles the Show All filter button.

If those are not the filters you’re referring to, please provide a screenshot to clarify.


#15

That (deleting in edit mode), of course, works, apologies for missing the obvious.
Thank You.


#16

Not a problem at all. Glad to help out.