Alloy Error with a new set-up


#1

Hi,

Anyone know why I am getting the following error while setting up a new Alloy blog?

Parse error: syntax error, unexpected ‘[’ in /home/garagesh/public_html/episcopal/blog/index.php on line 144

Thanks.
Blessings,
—Mark


#2

Hi Mark –

I’ll need more details on the problem to help diagnose it. When and where does this error occur? Do you have any blog posts in your posts folder?

Also, please send me a ZIP file containing your project file as well as a link to the live URL if possible.

And finally – what versions of RW, Stacks and Alloy are you using?


#3

Hi Adam,

I just Dled Alloy tonight for the first time, so I assume it is the latest version. RW 8.1 and Stacks 3.6.5

Added a page to my site for the blog and following the instructions from the set-up menu. So I do not have any posts nor is Alloy creating the posts folder.

The only thing I see that is strange is my project shows the filename as index.html and my server shows the file as index.php

Does Alloy change it?

I will package up the project if I can not figure it out.
Thanks.
Blessings,
—Mark


#4

Stacks changes pages to a PHP extension if the stacks within the page require PHP. Alloy is virtually all PHP, so the extension must be PHP. If you have already published the page with an HTML index file you’ll need to delete that index.html file from your server. I saw you emailed me, so I will go take a look at that in just a little while.


#5

Just shot you an email. When I published your project to my server all sent well. Sent you some questions. We’ll get you all sorted out.


#6

After talking with @garageshop it looks like this may be a case of the PHP version being older than v5.6, which is required for Alloy. Will update this thread once we see if an update to v5.6 or newer clears things up.


#7

Thanks, Adam for the incredible support!

A2 advertises that they allow the user to choose up to the latest version of php the 7+ yet on my cPanel, 5.5 is the max. I have a support ticket in.

Thanks again for helping me sniff this out!
Blessings,
—Mark


#8

Not a problem. Hopefully that’ll fix it up! :smiley:


#9

PHP 5.10 sort of worked, at least the basic function of the stacks worked, there were some random error codes printed on the page.

Version 7 works just fine, although my server company required me to upgrade my service to get to 7. Smarmy business practices since they offer 7 on all new accounts! When this contract expires, I will move my sites off to chili hosting!

Alloy makes a GREAT blog, so much easier than some of the other products I own and have looked at.

My only wish list for future development is the ability to click the topper to open a gallery view!

Thanks for the great support and great software.
Blessings,
—Mark


#10

That is very odd that they’d charge you to upgrade the PHP installation. Glad you got it sorted out though.


#11

Yeah, it is a pathetic up-sell, common tactic of the big ISP too!

Thanks.
Blessings,
—Mark